Habilitar el sonido surround 5.1 en Ubuntu


A pesar de que al contar con un sistema de sonido Surround 5.1 y Ubuntu lo reconoce, en varias ocasiones este no se activa del todo correctamente sobre todo en lo que respecta al sonido a través del sub-woffer. Mediante este tutorial, veremos como activar completamente el surround en Ubuntu.

El error de esto es que no todas las salidas se habilitan en el demonio pulse originando que algunos canales suenan y otros no (el sub-woffer por ejemplo), pues bien para solventar este detalle tenemos que realizar los siguientes pasos:

Abrimos la terminal y colocamos:

sudo gedit /etc/pulse/daemon.conf

esto nos abrira el texto donde estan configurados los parametros del demonio de sonido pulse, allí ubicamos la línea resample-method y modificamos de esta manera:

resample-method = speex-float-6
enable-remixing = yes
enable-lfe-remixing = yes

Luego ubicamos la línea default-sample-format y modificamos de la siguiente manera:

default-sample-format = s24le
default-sample-rate = 96000
default-sample-channels = 6
default-channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe

Guardamos estas modificaciones y en la terminal colocamos:

alsamixer

allí nos vamos hacia casi el final para encontrarnos con la opción channel, con la tecla de flecha arriba lo colocamos en 6, cerramos y reiniciamos.

Con esto ya tendremos todos los canales de audio surround 5.1 trabajando en Ubuntu.

Anuncios

11 comentarios en “Habilitar el sonido surround 5.1 en Ubuntu

  1. Gracias por la entrada.
    Quería preguntarte una duda. Uso la última versión de Kubuntu, he conseguido hacer funcionar correctamente el sonido 5.1 usando SPDIF digital, pero no lo consigo a través de hdmi.
    Si selecciono la salida hdmi digital 5.1 no funciona el audio. Solo funciona la salida Stereo digital hdmi 3.
    La duda que tengo es como hago para “editar” el perfil de stereo digital hdmi 3, y adaptarlo para 5.1
    Gracias de antemano

    Me gusta

  2. Hola buenas tardes…. Soy dario,no se casi nada de compus y quise usar lo q describen más arriba en mi compu con “archlinux”….. Y me quedé sin sonido …… Nada de nada… La uso con cable hdmi de una placa de de vídeo recientemente. Incorporada…. Que hago,como hago para tener sonido otra vez…. Muchas gracias!!!!

    Me gusta

    • Darío, tal vez este no es el lugar más adecuado para tu pregunta, porque se sale del tema.
      Nunca he usado Manjaro, pero hay aplicaciones que son comunes en varias distribuciones de linux.
      Es posible que la nueva configuración active el botón mute automáticamente.
      Si tiene Audio Mixer en el menú o ejecutas xfce4-mixer en la terminal. Revisa lo que te aparece ahí, si el problema es el automute, en la parte inferior hay un botón que dice: select controls
      ahí activa automute mode, este control va a aparecer en la pestaña options, desactivalo.
      Si jugar con el xfce4-mixer, no es suficiente, instala el pulseaudio-utils, te va a instalar una opción en el menú que es similar al Audio Mixer, pero con más opciones y tiene unos “decibelimetros” con los que puedes ver si hay alguna señal pero que no se escucha porque no está conectada virtualmente en la salida adecuada, vgr. las bocinas.
      Espero que esto te sirva, si no te saca del apuro, busca en los foros de Manjaro.

      Me gusta

      • Darío, contesté tu comentario por que lo ví en las ligas a los posts más recientes, por eso no había visto a qué te referías y te eché todo un rollo, que tal vez no te saque del apuro.
        Lo más sencillo que puedes hacer, es recuperar el respaldo del archivo /etc/pulse/daemon.conf para regresarlo a su configuración original, para que lo escuches al menos como antes.
        Cuando hagas cambios en archivos de configuración, comenta las lineas originales y agrega un comentario con la fuente en que te basas.
        Por lo general los comentarios comienzan con ‘#’, por ejemplo:
        # para activar el sonido 5.1 como dice en https://ubuntu.net ….

        Me gusta

      • Hola, podrian ayudarme puse sin querer en hadware el digital sourround 5.1 y ahora no lo puedo cambiar la pestaña de configuracion de sonido es muy chica y no puedo editar su tamaño ayuda no tengo sonido!!!

        Me gusta

  3. El problema que tengo al acabar de hacer los pasos es que el altavoz trasero derecho no se escucha en absoluto y los demás altavoces sí que se escuchan, pero al realizar la prueba de speaker-test -c6 resulta que los canales no se corresponden con los altavoces y ahí en el test sí que se oye el ruido para el altavoz trasero derecho. ¿Alguna sugerencia?

    Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

w

Conectando a %s