Solventar error “No se pudo bloquear el directorio de administración (/var/lib/dpkg/), ¿quizás haya algún otro proceso utilizándolo” en Ubuntu


En mas de una ocasión probablemente se habrá sufrido el error “No se pudo bloquear el directorio de administración (/var/lib/dpkg/), ¿quizás haya algún otro proceso utilizándolo” en Ubuntu, pues bien la solución es muy simple.

ubuntu-mir-logoPara eliminar este dicho error, simplemente abrimos la terminal y colocamos lo siguiente:

sudo rm /var/lib/apt/lists/lock

(Click enter y luego se coloca)

sudo rm /var/lib/dpkg/lock

(y click en enter)

Con esto habremos salido del dichoso error molesto de por sí.

Anuncios

8 comentarios en “Solventar error “No se pudo bloquear el directorio de administración (/var/lib/dpkg/), ¿quizás haya algún otro proceso utilizándolo” en Ubuntu

  1. Bueno, lo mejor seria como usuario root, hacer un pkill -9 apt-get . Luego de eso, reiniciar el sistema (recomendado), una vez iniciada la sesion nuevamente, proceder con la instalacion/mantenimiento previo sin el inconveniente en cuestion.

    Me ha funcionado matando el proceso, en caso contrario, pues, deberian hacer los pasos descritos en este post del blog.

    SaludoS!

    Me gusta

  2. estoy tratando de ejecutar: sudo apt-get install xorg
    tuve el problema que mencionas
    hice lo primero que recomendaste para el problema ……….pero ahora me sale otro error :
    no se pudo bloquear /var/cache/apt/archives/lock – open (11:recurso no disponible temporalmente)
    e: no se puede bloquear el directorio de descarga

    ayuda por favor!!!!!

    Me gusta

  3. hola mira me salio lo siguiente y sigo sin poder solucionarlo te paso dice esto “Descargados 1.690 kB en 42seg. (39,9 kB/s)
    Leyendo lista de paquetes… ¡Error!
    E: Encountered a section with no Package: header
    E: Problem with MergeList /var/lib/apt/lists/archive.canonical.com_ubuntu_dists_quantal_partner_i18n_Translation-en
    E: No se pudieron analizar o abrir las listas de paquetes o el archivo de estado.

    Me gusta

    • ese problema que describes es muy probable que este relacionado con un repositorio que ya no tiene mantenimiento, ya que “i18n_Translation-en” hace referencia a traducción y “ubuntu_dists_quantal_partner” hace alusión a una aplicación tipo flash player.

      ve al gestor de repositorios (en el centro de software ubica en el panel superior la opción editar – origenes de software – otros software) y desmarca “socios de Canonical” y prueba de nuevo.

      en todo caso, en “otros software” verifica si usas en realidad todos esos repositorios (talvez instalastes alguna vez un programa y luego lo desinstalaste y no se borro el repositorio de origen.

      Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s