Instalando ia32-libs en Ubuntu 14.04.2 y solventar el error de libgl-mesa i386


Muchos de los que solíamos usar Ubuntu 12.04 y aplicaciones que requerían las ia32-libs al migrar a Ubuntu 14.04 nos encontramos con la sorpresa de que esta ya no está disponible en los repositorios oficiales de Ubuntu 14.04, la causa de esto es que ya no haría falta pues la introducción del multi-arch por defecto remplazaría estas bibliotecas, pero hay aplicaciones que (y a estas alturas) aún no soportan el multi-arch, tal es el caso de Google Earth de 64 bits, pues bien, les diré como instalar ia32-libs en Ubuntu 14.04 y a su vez como solventar el error de libgl-mesa i386 en el segundo paquete de actualización mayor en la versión LTS mas reciente de Ubuntu.

ia32-libs-ubuntu-1404

En mi caso, uso la versión de 64 bits de Ubuntu 14.04 y la versión de Wine/crossover que mejor funciona con los juegos de Windows que suelo instalar en Ubuntu (FIFA’s, Silent Hill 2/3…) es la 12.1.0, pues bien, esta versión no soporta multi-arch y requiere de las bibliotecas ia32-libs, en Ubuntu 12.04 funciona sin problemas pero en la 14.04 no.

La solución a este problema nos la brindo nuestro amigo Jonatan en un comentario anterior en el cuál yo indicaba de que comenzaría a usar la PPA xedger: descargar e instalar ia32-libs desde pkgs.org, la peculiaridad de esto, es que tiene que ser la versión para Linux Mint 17.1 ya que la versión de Ubuntu 12.04 no funciona… es lógico después de todo ya que Linux Mint 17.1 está basada en Ubuntu 14.04.

Pero al tener instalado Ubuntu 14.04.2 por defecto (con Xorg 1.16, Linux 3.16 y Mesa 10.3) y tratar de instalar ia32-libs nos generará un error con respecto a libgl-mesa i386, al indagar en internet me encuentro con la sorpresa de que hay bastantes usuarios con el mismo problema, ya que dicho error impide que el cliente Steam se ejecute. La solución en mi caso fue la siguiente:

Abrimos la terminal y colocamos: sudo apt-get -s install libgl1-mesa-glx-lts-utopic:i386, luego de ejecutar dicho parámetro, lo volvemos a repetir pero en esta ocasión sin la -s, quedando entonces de la siguiente manera: sudo apt-get install libgl1-mesa-glx-lts-utopic:i386, con esto se solventa el dichoso error y podremos instalar ia32-libs sin problemas!!!

crossover-ubuntu-1404

Como dato adicional y recomendación, instale ia32-libs directamente con el centro de software, en lugar de guardar el binario, seleccionamos abrir con Centro de Software de Ubuntu desde Mozilla Firefox. ¡¡¡Importante!!! no se debe cerrar ni el navegador ni la pestaña de pkgs.org cuando se realice la instalación de ia32-libs.

Anuncios

15 comentarios en “Instalando ia32-libs en Ubuntu 14.04.2 y solventar el error de libgl-mesa i386

  1. Ahora me aparece:
    E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock» – open (13: Permiso denegado)
    E: No se encontró un archivo de réplica «/var/lib/dpkg/»

    de tantos comandos que puse en la terminal y de tantas cosas que instale desde el gestor de paquetes de synaptic nada me ah funcionado eh visto en otros post y tampoco espero puedan ayudarme.

    Me gusta

      • ola logre instalar el ia32-libs desde el centro de software descarge la version del 17.1 como dice el post pero aun asi cuando quiero abrir juegos o exe el wine sigue sin funcionar.
        (perdon la ignorancia pero soy nuevo)

        Me gusta

      • pues antes de cambiar de pc tenia una ubuntu 11.04 con wine y podia abrir el exe que estoy intentando pero no funciona y antes si talves me falte instalar algo del ia32-libs como cross over pero la verdad sigo sin entender

        Me gusta

      • como te dije todas las aplicaciones que intento ejecutar no funciona me tira error y cuando usaba el ubuntu de 32 bit si funcionaba por eso creo que hice algo mal pero nose que.
        instale el wine desde el centro de software luego de muchos comandos que ejecute en la terminal logre instalar el ia32-libs pero no funciono.

        Me gusta

      • Pudiera ser por la biblioteca libgl1 la cuál apunta a la anterior versión 14.04.2 la cuál estaba basada en 14.10 Utopic unicorn, intenta instalarla de la siguiente manera: sudo apt-get -s install libgl1-mesa-glx-lts-vivid:i386 y sudo apt-get install libgl1-mesa-glx-lts-vivid:i386 si usas claro, la versión 14.04.3 basada en el kernel 3.19 (puedes probar a ver corriendo el siguiente parámetro vía terminal: uname -a).

        unamea

        Si como resultado te dice que usas el kernel 3.19, entonces instálalo como te dije, si te da el 3.13 entonces lo instalas así: sudo apt-get -s install libgl1-mesa-glx:i386 y sudo apt-get install libgl1-mesa-glx:i386

        saludos!

        Me gusta

  2. Tengo un problema cunado quiero instalar el ia32-libs en la terminal me aparece:
    El paquete ia32-libs no está disponible, pero algún otro paquete hace referencia
    a él. Esto puede significar que el paquete falta, está obsoleto o solo se
    encuentra disponible desde alguna otro origen
    Sin embargo, los siguientes paquetes lo reemplazan:
    lib32z1 lib32ncurses5 lib32bz2-1.0

    y si busco ia32-libs desde el gestor de paquetes de synaptic no me aparece nada
    podrias ayudarme?

    Me gusta

  3. Hola! Te hago una consulta, cuando intento instalar me sale el siguiente error:
    hernan@hernan-N53Jf:~$ sudo apt-get -s install libgl1-mesa-glx-lts-utopic:i386
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    No se pudieron instalar algunos paquetes. Esto puede significar que
    usted pidió una situación imposible o, si está usando la distribución
    inestable, que algunos paquetes necesarios no han sido creados o han
    sido movidos fuera de Incoming.
    La siguiente información puede ayudar a resolver la situación:

    Los siguientes paquetes tienen dependencias incumplidas:
    libgl1-mesa-glx : Entra en conflicto: libgl1:i386
    libgl1-mesa-glx-lts-utopic:i386 : Depende: libglapi-mesa-lts-utopic:i386 (= 10.3.2-0ubuntu1~trusty2) pero no va a instalarse
    Depende: libgl1-mesa-dri-lts-utopic:i386 (= 10.3.2-0ubuntu1~trusty2) pero no va a instalarse
    Entra en conflicto: libgl1
    Entra en conflicto: libgl1-mesa-glx
    wine : Depende: wine1.6 o
    wine1.7
    wine1.6-i386:i386 : Depende: wine1.6:any:i386 (= 1:1.6.2-0ubuntu4)
    E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.
    hernan@hernan-N53Jf:~$ sudo apt-get install libgl1-mesa-glx-lts-utopic:i386
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    No se pudieron instalar algunos paquetes. Esto puede significar que
    usted pidió una situación imposible o, si está usando la distribución
    inestable, que algunos paquetes necesarios no han sido creados o han
    sido movidos fuera de Incoming.
    La siguiente información puede ayudar a resolver la situación:

    Los siguientes paquetes tienen dependencias incumplidas:
    libgl1-mesa-glx : Entra en conflicto: libgl1:i386
    libgl1-mesa-glx-lts-utopic:i386 : Depende: libglapi-mesa-lts-utopic:i386 (= 10.3.2-0ubuntu1~trusty2) pero no va a instalarse
    Depende: libgl1-mesa-dri-lts-utopic:i386 (= 10.3.2-0ubuntu1~trusty2) pero no va a instalarse
    Entra en conflicto: libgl1
    Entra en conflicto: libgl1-mesa-glx
    wine : Depende: wine1.6 o
    wine1.7
    wine1.6-i386:i386 : Depende: wine1.6:any:i386 (= 1:1.6.2-0ubuntu4)
    E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.

    Como datos adicionales se podria decir que uso kubuntu 14.04 lts y que tengo instalado bumblebee-nvidia ya que tengo una notebook con nvdia optimus.

    Ojalá me puedas dar una mano.
    Saludos

    Me gusta

    • es bastante sencillo, ahorita andan por la versión 14 pero en mi caso, la 12 es la que mejor funciona, aparte de que poseo una versión completa porque en aquel entonces se ofreció gratuitamente por 1 año.. el viene en un .deb, por lo que simplemente con un sudo dpkg -i *.deb tienes y si hay problemas con dependencias pues con un sudo apt-get -f install y luego con el sudo dpkg -i *.deb tienes 🙂 pero si, probablemente haga un tuto a petición del publico 😉 xD

      Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s