Proponen debatir nuevamente el caso de Firefox en la próxima UDS de Ubuntu


Firefox nuevamente vuelve a estar en la mira de los desarrolladores de Ubuntu, al respecto Bryan Quigley ha propuesto a través de la lista de correo de Ubuntu, debatir nuevamente sobre si incluirlo por defecto en la próxima LTS 16.04.

ubuntu-mir-logoEl debate sobre si incluir Firefox por defecto en Ubuntu no es algo nuevo pero en esta ocasión parece tener mucho sentido luego de que se anunciase el fin del soporte para todas las extensiones NPAPI a excepción de Flash Player en el popular navegador web, si bien el debate no tendría mucho sentido si se tratase de las versiones para Windows, hay que recordar que el soporte para Flash Player 11.2 (la cuál es la última versión soportada para Linux) finaliza su ciclo de vida por parte de Adobe en el 2017 y actualmente dicha versión ocasiona numerosos fallos debido a que esta escrita en GTK2 y tiene muchas dependencias con HAL (esta última característica fue retirada de Ubuntu hace algunos años).

¿qué pasaría si no se toman cartas en el asunto? pues como indicó Bryan Quigley pasaría lo siguiente: Si no se hace nada para la 16.04 LTS: en 8 meses dejaran de funcionar todas las extensiones NPAPI a excepción de Flash Player y en 10 meses luego del lanzamiento de Ubuntu 16.04, dejará de funcionar Flash Player (a excepción de que se tome el absurdo riesgo de mantener dicho plugin sin contar con actualizaciones por parte de Adobe) ya que Adobe finalizará su soporte en 2017.

Vale recordar que a partir del 2017, Adobe dejará de soportar la versión 11.2 de Flash Player y únicamente ofrecerá actualizaciones para flash basado en PPAPI, si bien en Google Chrome esto no es ningún problema en Firefox si que lo es ya que sus desarrolladores no tienen interés alguno en soportar dicha API, Además es importante señalar que Canonical ofrece una versión de Chromium con PPAPI Flash Player en sus repositorios por lo que es probable que finalmente Firefox sea remplazado por Chromium en la próxima LTS de Ubuntu 16.04

Es de recordar que si los desarrolladores de Ubuntu decidiesen remplazar Firefox por Chromium como navegador web por defecto, esto no significa que no estará mas presente en la popular distribución de Canonical, pues Mozilla Firefox estará disponible a través de los repositorios oficiales y será mantenido como se viene haciendo actualmente.

Puedes conocer todos los detalles al respecto remitiéndote a la lista de correo de Ubuntu.

Anuncios

6 comentarios en “Proponen debatir nuevamente el caso de Firefox en la próxima UDS de Ubuntu

    • el problema no es firefox en sí, es por flash player basado en NPAPI el cuál es el que soporta Mozilla Firefox, dicho plugin tiene al parecer muchas dependencias con HAL (esta característica fue retirada de Ubuntu hace ya algunos años atrás) y con GTK2… la diatriba que tiene ahora Canonical es que Firefox no quiere nada con PPAPI la cuál será la única versión que Adobe soportará para Linux (pues el soporte para Flash player NPAPI11.2 finaliza en el 2017)… si todos los portales de vídeos estuviesen migrados a HTML5 este problema no se presentaría pero lamentablemente esto no es así.

      las versiones no-lts no tendrían mayores problemas pero la próxima LTS si que representa un problema, ya que si Firefox se mantiene como navegador por defecto, al entrar el 2017, varias páginas webs que ofrecen contenido multimedia mediante Flash Player quedarían inactivas e inservibles (a excepción de que Ubuntu mantenga flash player 11.2 en sus repositorios, algo que sería totalmente irresponsable y absurdo por los enormes riesgos de seguridad que representaría)… creo que en esta oportunidad el “zorro de fuego” será remplazado finalmente por Chromium (también recuerda que Ubuntu ofrece una versión de Chromium con Flash Player PPAPI habilitado por defecto), a excepción claro que Ubuntu “pise el acelerador” con respecto a su navegador web Ubuntu Internet Browser y lo ofrezca por defecto en la próxima LTS 16.04 algo que en lo personal lo veo poco viable.

      Me gusta

      • Mozilla en ningún momento han pensado en semejante disparate como lo es integrar un plugin de terceros (como lo es Flash Player), simplemente que a partir del 2017, los usuarios de Linux no podrán visualizar contenido multimedia basado en Flash usando Mozilla Firefox y es ahí el punto que quieren debatir en Canonical, claro puedes usar por ejemplo Fresh Flash Player el cuál básicamente te permite usar la versión de flash player que viene en Google Chrome (la cuál seguirá teniendo soporte por parte de Adobe) en Mozilla Firefox, pero esta no sería la solución idónea… ojala y todos los sitios estén migrados a HTML5 a mas tardar a mediados del año 2016, pero es poco probable que se cumpla..

        Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s