Se lanzan nuevas versiones de seguridad del kernel Linux para todas las versiones soportadas en Ubuntu


La gente de Canonical ha lanzado el día de hoy nuevas versiones de actualización del kernel Linux para todas las versiones de Ubuntu soportadas actualmente, es decir la 12.04, (original y HWE-LTS), 14.04 (tanto la versión original como la provista a través del HWE), para las ediciones de Raspberry Pi 2, y la 15.10

ubuntu-securityLas nuevas versiones 4.2.0-30.35 (Wily, Trusty-LTS, y Raspberry Pi 2), 3.13.0-79.123 (Trusty original y precise-LTS) y 3.2.0-99.139 (Ubuntu 12.04 stack original) del kernel Linux han sido lanzadas el día de hoy para todas las versiones soportadas de Ubuntu, en dichas versiones de seguridad se corrigen varias vulnerabilidades como:

Kernel 4.2.0-30.35

(versión incluida en Ubuntu Wily werewolf 15.10, las nuevas versiones para la Raspberry Pi y en la cuarta actualización puntual de Ubuntu 14.04)

  • Se corrige un problema de seguridad cuando OverlayFS era montado de manera incorrecta en el FUSE
  • Se corrige un problema de seguridad en OverlayFS el cuál permitiría propagar atributos de archivos como POSIX ACLs
  • Se corrige un error en el kernel Linux el cuál no aplicaba correctamente los límites de descriptores de archivos enviados a través de sockets de dominio UNIX.
  • Se corrige un error el cuál el sistema de archivo en el espacio de usuario (FUSE) el cuál no manejaba adecuadamente los segmentos iniciales con longitud cero
  • Se corrige un error en el manejo de eventos de flujos en el TLB (translation lookaside buffer) del kernel Linux

Kernel 3.13.0-79.123

  • Se corrige un problema de seguridad cuando OverlayFS era montado de manera incorrecta en el FUSE
  • Se corrige un problema de seguridad en OverlayFS el cuál permitiría propagar atributos de archivos como POSIX ACLs
  • Se corrige un error en el subsistema keyring del kernel Linux
  • Se corrige un error en la implementación de red en el Kernel Linux el cuál no validaba correctamente los identificadores de algunos protocolos
  • Se corrige un error en la implementación pptp del kernel Linux el cuál no identificaba la longitud de direcciones cuando se configuraba un socket
  • Se corrige un error en la implementación del bluetooth en el kernel Linux el cuál no validaba correctamente la longitud de dirección de un socket en sockets SCO (Synchronous Connection-Oriented).
  • Se corrige un error en el sistema de archivo de Linux en el espacio de usuario (FUSE)el cuál no manejaba adecuadamente los segmentos iniciales con longitudes cero

Kernel 3.2.0-99.139

  • Se corrige un error en el subsistema keyring del kernel Linux

Estas versiones de actualización ya deberían estar disponibles en el gestor de actualizaciones de Ubuntu. Puedes conocer todos los detalles remitiéndote a los siguientes enlaces:

Kernel 4.2.0-30.35 Ubuntu 15.10
Kernel 4.2.0-30.35 Raspberry Pi 2
Kernel 4.2.0-30.35 Ubuntu 14.04 HWE-LTS
Kernel 3.13.0-79.123 Ubuntu 14.04 Original Stack
Kernel 3.13.0-79.123 Ubuntu 12.04 HWE-LTS
Kernel 3.2.0-99.139 Ubuntu 12.04 stack original

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s