X11 hace vulnerable la seguridad en los paquetes Snap de Ubuntu


Matthew Garrett ha publicado un artículo en donde señala que si bien los nuevos paquetes Snap brindan una fuerte seguridad y facilidad para distribuir aplicaciones en Ubuntu, estos tendrían que estar acompañados del servidor gráfico Mir o Wayland ya que X11 carece realmente de una infraestructura de seguridad en cuanto al sandboxing en las aplicaciones.

xorg-bugA través de su blog oficial, Matthew Garrett ha señalado que de nada sirve tanta seguridad que brindan los nuevos paquetes Snap (los cuales están soportados en la reciente versión 16.04 de Ubuntu) de Ubuntu si el sistema operativo aún continua usando el servidor de ventanas gráfico X11 ya que este permite que las aplicaciones copien y envíen datos privados del usuario sin muchas dificultades a servidores remotos.

Garrett señaló lo siguiente con respecto al problema que tiene X11 actualmente con el nuevo concepto de seguridad usado en los nuevos paquetes Snap:

“X no tiene un concepto real en cuanto a los diferentes niveles de seguridad en las aplicaciones. Cualquier aplicación puede registrar las pulsaciones del teclado desde otra aplicación, cualquier aplicación puede inyectar eventos importantes falsos en los flujos de entrada del sistema. Cualquier aplicación que esté limitada por fuertes políticas de seguridad simplemente se puede escribir en otra ventana. Una aplicación que no tenga acceso a la data privada del usuario puede esperar hasta que la sesión del usuario esté inactiva, luego abrir un terminal en un lugar no confinado y usar curl para enviar la data a un servidor remoto. Mientras Ubuntu continúe usando X11, la seguridad de los paquetes Snap será insignificante. Mir y Wayland solucionan estos problemas.”

Como vemos, X11 al día de hoy representa mas un obstáculo que un impulso en cuanto a las nuevas tecnologías para Linux por lo que se requiere avanzar mas rápido en el desarrollo de los servidores de ventanas de próxima generación como Mir y Wayland para “poner al día” las distribuciones Linux mas populares al día de hoy, como lo es Ubuntu.

Si deseas conocer todos los detalles deberás remitirte al blog oficial de Matthew Garrett.

Anuncios

4 comentarios en “X11 hace vulnerable la seguridad en los paquetes Snap de Ubuntu

  1. Ya lo suponía. Pero es que la forma en que se están redactando las noticias sobre esto transmiten la idea de que lo inseguro son los paquetes snap, cuando en realidad se trata del papel que juerga x11 en el sistema en general.

    No estaría de más echar un poquito de luz sobre este asunto, porque la idea que se está dandop es equivocada.

    Me gusta

    • Bueno de hecho por eso puse como encabezado que es X11 el que vulnera la seguridad de los paquetes Snap… pues si se colocase como lo puso Garreth en su blog: “Eludiendo el confinamiento de Ubuntu Snap” si diera a entender de que son los paquetes Snaps y Ubuntu los que ofrecen una seguridad muy baja…

      Me gusta

  2. Hola, Ramón.

    Tengo una duda respecto a esto.

    Garret dice que la paquetería snap no es segura debido a problemas de seguridad de x11. Bien, correcto, no tengo conocimientos nin motivos para dudarlo.

    Mi duda es la siguiente: ese problema de seguridad afecta solo a la paquetería snap, o también al sistema en general y, en consecuencia, también a los paquetes .deb que todos tenemos instalados?

    Lo digo porque, si estoy en lo cierto, que no lo sé, se trataría de un problema que ya tendríamos ahora, que existiría desde hace mucho tiempo, y que no tendría nada que ver con los paquetes snap, por lo que no haría falta mencionarlos siquiera.

    Saludos.

    Me gusta

    • Es un problema de hace mucho tiempo que comienza a “salir a la luz” con las nuevas tecnologías en cuanto a seguridad se refiere, de hecho cuando comenzó el desarrollo de Wayland uno de los objetivos principales era eso mismo, X11 debido a su arquitectura se hace ya obsoleto para soportar las nuevas políticas de seguridad actuales. Sería como usar por ejemplo la reciente versión de Mozilla o Chrome en Windows 98… por mas seguridad que brinde el navegador de nada va a servir si el sistema no ayuda en ello, claro puedes disfrutar de nuevas características pero el nivel de seguridad será mínimo.

      Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s