Las GPU’s integradas de Intel a partir de la cuarta generación usarán por defecto el controlador gráfico xf86-video-modesetting en Debian y Ubuntu


Tanto la gente de Debian como la de Ubuntu han decidido remplazar el antiguo controlador gráfico xf86-video-intel de X.org por el genérico xf86-video-modesetting en las GPU’s integradas de Intel que sean de cuarta generación y superior, es decir, que a partir de los modelos GMA 3000 se usará el driver xf86-video-modesetting por defecto en dichas distribuciones Linux.

ubuntu-debianTimo Aaltonen, un desarrollador del área de gráficos en Ubuntu ha anunciado a través de su blog, que tanto los desarrolladores de Debian como los de Ubuntu han decidido remplazar el controlador gráfico xf86-video-intel de X.org por el genérico xf86-video-modesetting en todas las GPU’s integradas de Intel que sean de cuarta generación (GMA 3000) en adelante, esto obviamente significan buenas noticias para todos los usuarios linuxeros que usan gráficos integrados de Intel.

De acuerdo con el anuncio, este cambio se hará próximamente en las versiones de desarrollo Debian Stretch y Ubuntu Yakkety aprovechando así el reciente lanzamiento de X.org Server 1.18.4 el cuál incluye numerosos arreglos en los backports de glamor y en los controladores gráficos que operan bajo el método de configuración modesetting. Este cambio permitirá ahora que estas GPU’s puedan realizar operaciones de aceleramiento 2D sobre OpenGL usando el mismo módulo genérico de glamor que usan los controladores radeon/amdgpu.

Vale reseñar que para los usuarios que usen GPU’s Intel de segunda y tercera generación, Aaltonen trabaja en un parche que permitiría correr ciertas funcionalidades de Glamor.

Si deseas conocer todos los detalles sobre estos nuevos cambios, entonces deberás remitirte al blog de Timo Aaltonen.

Vía: Phoronix

Anuncios

2 comentarios en “Las GPU’s integradas de Intel a partir de la cuarta generación usarán por defecto el controlador gráfico xf86-video-modesetting en Debian y Ubuntu

  1. sacame de una duda, si estoy en debian SID instalado ayer por ejemplo, ya tengo ese nuevo driver? o debo desinstalar el x86-video-intel para que este nuevo sea reconocido? no entiendo

    Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s